Install Unity3D di Ubuntu 16.04

Unity3D merupakan perangkat lunak yang berfungsi untuk membuat sebuah aplikasi atau game. Bisa dikatakan aplikasi ini adalah sebuah game engine, dimana kita dapat membuat game berbasis 3D maupun 2D. Hasil dari game ini dapat kita eksport menjadi beberapa aplikasi yang dapat berjalan pada sistem operasi Linux, Windows, Mac, Android dan IOS.

Unity3D dapat berjalan secara multiplatfrom, yang artinya dapat berjalan tidak hanya pada satu sistem operasi saja, aplikasi ini dapat berjalan pada sistem operasi Windows, Mac, dan Linux. Akan tetapi Website resminya sendiri tidak mempublish untuk platfrom Linux. Maka dari itu saya akan menjelaskan bagaimana cara menginstall aplikasi ini pada sistem operasi linux yang salah satunya adalah Ubuntu 16.04.

Pertama download terlebih dahulu Unity3D versi stable dan terbaru, saya sendiri menggunakan Unity3D versi 5.4.1. Download Disini

Setelah itu buka terminal, lalu install Unity3D menggunakan perintah dibawah ini.

sudo dpkg -i Downloads/unity-editor-5.4.1f1+20160913_amd64.deb

Apabila terdapat error pada saat proses installasi seperti dibawah ini.

[email protected]:~$ sudo dpkg -i Downloads/unity-editor-5.4.1f1+20160913_amd64.deb
Selecting previously unselected package unity-editor.
(Reading database ... 275876 files and directories currently installed.)
Preparing to unpack .../unity-editor-5.4.1f1+20160913_amd64.deb ...
Unpacking unity-editor (5.4.1f1) ...
dpkg: dependency problems prevent configuration of unity-editor:
unity-editor depends on lib32gcc1 (>= 1:4.1.1); however:
Package lib32gcc1 is not installed.
unity-editor depends on lib32stdc++6 (>= 4.6); however:
Package lib32stdc++6 is not installed.

dpkg: error processing package unity-editor (--install):
dependency problems - leaving unconfigured
Processing triggers for bamfdaemon (0.5.3~bzr0+16.04.20160824-0ubuntu1) ...
Rebuilding /usr/share/applications/bamf-2.index...
Processing triggers for gnome-menus (3.13.3-6ubuntu3.1) ...
Processing triggers for desktop-file-utils (0.22-1ubuntu5) ...
Processing triggers for mime-support (3.59ubuntu1) ...
Processing triggers for hicolor-icon-theme (0.15-0ubuntu1) ...
Errors were encountered while processing:
unity-editor

Lakukan perintah dibawah ini untuk memperbaikinya.

Sudo apt-get install -f

Setela proses installasi selesai, kamu bisa membuka unity3D yang ada pada menu dash ubuntu.

selection_038

Oke, Unity3D sudah siap untuk digunakan. Kamu bisa membuat berbagai aplikasi game menggunakan engine ini seperti Augmented Reality dan Virtual Reality.

Artikel Terkait